Print    
 
 
 
   
Advisory!

Due to systems upgrade of BIR, it is recommended for:

  • - Security Administrators to use INTERNET EXPLORER
  • - Authorizers and Verifiers to use INTERNET EXPLORER
  • - Makers with new passwords please do the ff.:

- Makers who will do on-line tax payments (EFPS), please do the ff.:

To download the installers, please click the link below;


IE

Firefox